kgrid.x fails in call spg_get_symmetry

Submitted by malwi on Fri, 11/01/2013 - 07:56

Forums 

Bug reports

Dear BGW Developers,

We want to use the BGW code for crystals. First of all it runs for molecules.
But there is a problem for crystals with the kgrid.x code. We try to run the example for silicon for ESPRESSO.
The code is hanging for hours (both parallel and serial run). The subroutine Commons/symmetries.f90
gives wrong parameter ntran_temp2 = -20384 after call to
call spg_get_symmetry(ntran_temp2, mtrx_inv(1,1,1), tnp_temp(1,1), ntran_temp, C_avec (1,1), apos(1,1), atyp(1), nat, symprec)
and the program hangs at
if(ntran_temp2 /= ntran_temp) call die("Inconsistent number of symmetries from spglib . Internal error.")

Our version is BGW-1.0.4 and we have AIX system on IBM Power 775.

Thank you in advance,
Malgorzata Wierzbowska (University of Warsaw)

dstrubbe's picture

Submitted by dstrubbe on Fri, 11/01/2013 - 15:15

See the comment in the name of this topic: "Please confirm that your build passes the testsuite first." Did you? If so, please specify what crystal you are talking about.

Submitted by malwi on Tue, 11/05/2013 - 01:47

testsuit failed as below. Due to segmentation fault

Starting test run ...
Executing: cd tmp/BGW.awlGGL; /home/users/malwi/BerkeleyGW-1.0.4/testsuite/../bin/epm2bgw.x < WFN.in > WFN.out
ATTENTION: 0031-408 4 tasks allocated by Resource Manager, continuing...
ERROR: 0031-250 task 0: Segmentation fault
ERROR: 0031-250 task 3: Segmentation fault
Elapsed time: 9.2 s

testfile # failed testcases
--------------------------------------------------------------------
CUBE/CUBE.test 1
GaAs-EPM/GaAs.test 1
Graphene/Graphene.test 1
Graphene/Graphene_3D.test 1
Si-EPM/Si.test 1
Si-EPM/Si_cplx.test 1
Si-EPM/Si_cplx_spin.test 1
Si-Wire-EPM/Si_wire.test 1
Silane-PARATEC/Silane.test 1

dstrubbe's picture

Submitted by dstrubbe on Wed, 11/06/2013 - 08:30

Please upgrade to 1.0.5, it is possible that will help. But your main problem is that you are trying to run serial codes in parallel. Neither kgrid nor epm2bgw should be run in parallel as they do not use MPI. You need to find a different way of running the testsuite that doesn't try to use 4 MPI tasks for even commands without "mpirun" or equivalent.